Avg MPG not working

breynolds63

Well-Known Member
Dec 11, 2016
22
2
123
58
Frankfort, IN
On my 2016 standard AT.....my dash used to tell me what my average mpg is. It now just shows "--" Anyone know how to make it work again?

Sent from my SM-G965U using Tapatalk
 

Graves

Moderator
Staff member
Legendary Rider
Aug 14, 2016
1,581
521
233
So. Cal.
On my 2016 standard AT.....my dash used to tell me what my average mpg is. It now just shows "--" Anyone know how to make it work again?

Sent from my SM-G965U using Tapatalk
Tank full or all levels?
 

belrix

Well-Known Member
Nov 2, 2015
877
440
208
52
SouthEast Kansas
What happens when you reset trip meter #1?. That should reset the avg MPG. Is the instantaneous MPG readout working?
 

Graves

Moderator
Staff member
Legendary Rider
Aug 14, 2016
1,581
521
233
So. Cal.
No problems with the fuel gauge? The reason I ask is when my sender broke the fuel gauge would go into an error and the average consumption wouldn't work. It might just be time to start with a full diagnostic of the dash unit. Start by checking all powers, grounds and inputs.
 

About us

  • Africatwin.org was established in 2015 to provide adventure motorcyclists an online community focusing on the Honda Africa Twin. The forum has grown exponentially through the years with excellent and insightful content. As a result of our growth, africatwin.org has expanded its media network to provide editorial content to the adventure riding community. Africatwin.org is not affiliated with Honda Motor Co. and any opinions expressed on this website are solely those of the author and do not represent Honda Motor Co. or africatwin.org.

Quick Navigation

User Menu